www.hiluxsurf.co.uk

Search this site:

Google:
Yahoo:
MSN:

Home Surf FAQ


Go Back   Hilux Surf Forum > HILUX SURF FORUMS - TECHNICAL > 2.4 & 2.8

Reply
 
Thread Tools Display Modes
Old 24th September 2004, 22:00   #1
alaned
Registered User
 
Join Date: Sep 2004
Location: Manchester
Posts: 7
Default Over drive light flashing ???!!!

Hi I have had my surf for 4 months now and until a fatal mistake on my part which caused my auto box to have no reverse (but i wont go in to that ) and being 1500 lighter i have my over drive light flashing when over drive is on!!

also the car has been juddering, the garage who ripped me off dont want to know and say its most likey a computer fault, I belive this to be bull as there was no probs until they removed the gearbox,

Any help would be most welcome

Kreg 2.4 and i love it
Attached Images
File Type: jpg surf.jpg (60.7 KB, 8 views)

Last edited by alaned; 27th September 2004 at 22:34.
alaned is offline   Reply With Quote
Old 25th September 2004, 11:38   #2
rich
JD Powered
 
rich's Avatar
 
Join Date: Aug 2003
Location: Thatcham, Berkshire
Posts: 1,058
Default

Oh dear did you undo the actuator cover on the gearbox - been there, same light bank account.

The flashing O/D light is telling you that there is still a problem with the Autobox, I think Fieldsy had the same problem a while back.

Looks like they didn't help you much, one thing to check is that all of the electrical connectors are back on the gearbox properly, if they are not then the speed sensor for the box, etc wont work right.

Rich.
__________________
If life's an uphill struggle then downhill from now on can't be that bad?!
rich is offline   Reply With Quote
Old 25th September 2004, 12:20   #3
TonyN
Super Moderator
 
TonyN's Avatar
 
Join Date: Aug 2003
Location: Basingstoke, Hants
Posts: 16,571
Default

If the garage has fitted a new gearbox, take it back. The O/D light means a problem with the gearbox, or things not fitted properly.

Didn't dump it in reverse while going forwards???
__________________
4x4toys.co.uk - Keeping you on and off the road...
TonyN is offline   Reply With Quote
Old 25th September 2004, 13:35   #4
Fieldsy
Blue is oh!,so yesterday
 
Join Date: Aug 2003
Location: Essex
Posts: 728
Default

yep, orange flashing o/d light is internal gearbox prob. There is a box in the engine bay which when shorted out can give the error code (number of blinks of the light).

I had mine checked and tested by an auto box specialist and there were no internal major problems. The box was changing properly and holding pressure fine through all the gears. The problem with the light was a lazy solenoid in the box. The solenoids are meant to fire in within a certain time and if they are lazy as mine was, it sends the error, but i'm not saying this is your problem, as the flashing o/d covers many faults/errors.There are, I believe 4 different speed solenoids in the box.

The solution to fix mine was rather extreme...................my missus smashed it into a tree ,wrote it off (not on purpose, I might add) and we bought another one..................with no flashing light


Have you also checked your tranny fluid level???

hope you get it sorted, I'll try and find some more info for ya

Last edited by Fieldsy; 25th September 2004 at 13:37.
Fieldsy is offline   Reply With Quote
Old 25th September 2004, 14:51   #5
Fieldsy
Blue is oh!,so yesterday
 
Join Date: Aug 2003
Location: Essex
Posts: 728
Default

here's a few to be looking through, but I personally would get a diagnostic on it to check the error codes.

http://www.t4x4pickup.com/dgroup/messages/2711.html


http://www.off-road.com/toyota/tech/codes/index.html

http://uktoyotaestimasite.tripod.com/obdcodes.htm


and some more

http://www.yotatech.com/showthread.p...ng+o%2Fd+light


http://autorepair.about.com/library/faqs/bl911g.htm
Fieldsy is offline   Reply With Quote
Old 26th September 2004, 16:02   #6
alaned
Registered User
 
Join Date: Sep 2004
Location: Manchester
Posts: 7
Default Thank's for all your help :)

Thank you all or your replies
i wont be hitting a tree just yet but it is an option
I have found a loose connector towards the back of the box on the drivers side, this seems to have stopped the gear box snagging but that just may be a coincidence, the connector had been siliconed in ??
I have done 150 miles since and so far ok just for this blinkin light
alaned is offline   Reply With Quote
Old 26th September 2004, 19:58   #7
BUSHWHACKER
Professor
 
BUSHWHACKER's Avatar
 
Join Date: Feb 2004
Location: Gwent.
Posts: 32,190
Default flashing o/d light

I was "experimenting" with the high and low ratios of auto box today, (on loose gravel of course) and my O/D light started flashing.
It turned out to be that the H4/N/L gear lever was'nt engaged properly. phew!

Last edited by BUSHWHACKER; 30th September 2004 at 20:29.
BUSHWHACKER is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:29.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Copyright 2004 the webmaster

 

   Address - N White, PO Box 278 Stevenage, Herts, SG1 1ZU, UK

 

All information and images on this website remain the property of the owner and no use shall be made of them elsewhere in whatever format without the express permission of the owner. All Corporate trademarks are the property of their respective owners.
You may freely link to this website however ownership of material remains as stated above.

                                                

 Contact us: toyota@hiluxsurf.co.uk